Degraded performance
Incident Report for MyOnlineStore
Postmortem

Nederlands

Het zal jullie niet zijn ontgaan dat vanmorgen (21 juni) tussen 08.34 uur en 9.20 uur (CEST) een verstoring heeft plaatsgevonden aan het platform van Mijnwebwinkel. Dit kwam doordat Cloudflare te maken had met een storing die wereldwijd vele websites heeft geraakt. Tussen de genoemde tijden waren jouw webwinkel en beheeromgeving niet of minder goed bereikbaar. Bij het bezoeken van je webwinkel, de beheeromgeving en de website van Mijnwebwinkel werd een 500 Internal Server Error getoond. 

De verstoring werd direct door verschillende geautomatiseerde controles in ons platform geconstateerd en alarmeerde het storingsdienststeam. Zij zijn direct in actie gekomen, maar concludeerden al snel dat de problemen bij Cloudflare, een externe dienst waar Mijnwebwinkel gebruikt van maakt, speelden. Via onze statuspagina en diverse andere kanalen, zoals social media en e-mail, hebben we je zo goed als mogelijk op de hoogte gehouden over het verloop van deze storing.

Cloudflare is wereldwijd één van de grootste partijen die veilig internet verzorgd. Ook Mijnwebwinkel maakt gebruik van enkele diensten van Cloudflare. Zo zetten wij Cloudflare onder andere in voor cyber security, om je webwinkel te beschermen tegen zogenaamde Distributed Denial of Service (DDoS) aanvallen. Ook zijn zij de partij die voor een groot deel verantwoordelijk is voor het verstrekken van SSL-certificaten, zodat jouw webwinkel veilig te bereiken is voor je klanten. Doordat zij zo’n grote speler zijn, waren de gevolgen van deze storing in grote delen van de wereld merkbaar. Diverse media, zoals Tweakers.net en Nu.nl, ontging deze verstoring niet.

De veiligheid en bereikbaarheid van jouw webwinkel zijn onze hoogste prioriteit. We werken daarom samen met enkele van de meest betrouwbare partners in de branche. Het is ons doel om onze diensten continu te optimaliseren en ongemakken zoals deze te voorkomen. Ook naar aanleiding van deze storing zullen wij daar waar mogelijk onze processen en techniek bijsturen om die veiligheid en bereikbaarheid te kunnen blijven garanderen.

English

As you may have noticed, this morning (June 21) between 08.34 and 9.20 am (CEST) there was a disruption to the MyOnlineStore platform. A worldwide Cloudflare outage affected many websites worldwide, which affected us too. As a result, your webshop and back office were not or less accessible between the times mentioned. When visiting your webshop, the back office and the website of MyOnlineStore, a 500 Internal Server Error was displayed.

This disruption was immediately detected by various automated checks in the MyOnlineStore platform and alerted our response team. They immediately took action, but soon concluded that the problems were at Cloudflare, an external service that MyOnlineStore uses. We have kept you informed as best as possible about the progress of this outage via our status page and various other channels, such as social media and email.

Cloudflare is one of the largest parties worldwide that provides secure internet. MyOnlineStore also uses some Cloudflare services. For example, we use Cloudflare for the cyber security of our platform, to protect your webshop against so-called Distributed Denial of Service (DDoS) attacks and they are the party that is largely responsible for providing SSL certificates, so that your webshop can be reached safely for your customers. Because they are such a large player, the consequences of this failure were noticeable in large parts of the world.This was also covered by media, such as Techcrunch.

The security and accessibility of your online store are our priority. That's why we work with some of the most trusted partners in the industry. It is our goal to continuously optimize our services and prevent inconveniences like this. As a result of this malfunction, we will also adjust our processes and technology where possible to continue to guarantee safety and accessibility.

Posted Jun 21, 2022 - 15:59 CEST

Resolved
De storing is voorbij en het platform is weer stabiel.

EN: The incident is over and the platform is stable again.
Posted Jun 21, 2022 - 10:15 CEST
Monitoring
Cloudflare heeft een oplossing geïmplementeerd. We houden het platform nauwlettend in de gaten.

EN: Cloudflare has implemented a fix. We are closely monitoring the platform.
Posted Jun 21, 2022 - 09:25 CEST
Update
Cloudflare werkt momenteel aan het implementeren van een potentiële oplossing.

EN: Cloudflare is currently working on implementing a potential fix.
Posted Jun 21, 2022 - 09:03 CEST
Identified
Een storing bij Cloudflare zorgt momenteel wereldwijd voor problemen. Zij zijn in onderzoek naar de oorzaak van het probleem, om zo spoedig mogelijk een oplossing te implementeren. Hierdoor zijn je webwinkel en beheeromgeving momenteel niet bereikbaar.

EN: A Cloudflare outage is currently causing problems worldwide. They are investigating the cause of the problem, in order to implement a solution as soon as possible. As a result, your webshop and back office are currently unavailable.

https://www.cloudflarestatus.com/
Posted Jun 21, 2022 - 08:47 CEST
Investigating
We signaleren op dit moment verminderde performance op ons platform. Dit kan leiden tot langere laadtijden en in extreme gevallen tot foutmeldingen. We zijn aan het onderzoeken waar de oorzaak ligt.

EN: We are noticing degraded performance across the platform. This may lead to longer loading times and in extreme cases even error messages. We are researching the cause of the incident.
Posted Jun 21, 2022 - 08:36 CEST
This incident affected: Platform (Back office, Storefront, Checkout, API).