Power outage
Incident Report for MyOnlineStore
Resolved
The weather is somewhat clearing up, the power has been restored and we are working on reducing the current delay.
Posted 2 months ago. Jun 12, 2019 - 12:50 CEST
Investigating
Due to heavy rainfall we're dealing with a local power outage and water leakage at our support department. We're unable to answer the phone and e-mail responses can be delayed.
Posted 2 months ago. Jun 12, 2019 - 12:14 CEST
This incident affected: Support.